Question Impossible d'utiliser WAMP, le port 80 est utilisé par IIS 7.5


J'essaie d'utiliser WAMP sur Windows 7, mon WAMP est en ligne, mais quand j'ouvre localhost, je reçois la page d'accueil d'IIS 7.5, bien que j'ai désinstallé IIS 7.5 de mon PC!

Le test du serveur Apache indique que le port 80 est utilisé Microsoft-HTTPAPI / 2.0

MS Visual Studio 2010 a également été désinstallé il y a peu de temps.


46
2018-03-08 16:56


origine


Réponses:


Par défaut, WampServer est installé sur le port 80 déjà utilisé par IIS. Pour configurer WampServer afin qu'il utilise un port ouvert, cliquez avec le bouton gauche de la souris sur l'icône WampServer dans la barre d'état système et accédez à Apache> httpd.conf.

Ouvrez le httpd.conf dans le Bloc-notes. appuyez sur Ctrl + F et recherchez "Listen 80", changez cette ligne à "Listen 8080" (vous pouvez changer ce port comme vous voulez), puis fermez et enregistrez le fichier httpd.conf.

Ouvrez un navigateur Web et entrez "[]; cela ouvrira la page de configuration de WampServer où vous pourrez configurer Apache, MySQL et PHP.

et parfois ce problème peut se produire en raison de skype également utiliser 80 comme port par défaut J'espère que cela aidera


33
2018-03-08 17:07



J'ai eu beaucoup de problèmes avec cette erreur (Merci à Microsoft - Grrr !!)

Enfin trouvé la solution ..... je partage cette solution

Il existe plusieurs façons d’arrêter IIS 7.5

  • Le meilleur est:

    Ouvrez une invite CMD (en tant qu'administrateur) et tapez ceci:

    iisreset / stop Voici un instantané:

    Image

  • Option suivante si vous ne pouvez toujours pas arrêter l'IIS 7.5

    Essayer ce lien vidéo.

  • La dernière option consiste à modifier le numéro de port comme dernière option. httpd.conf

PS: N'oubliez pas de redémarrer le WAMP une fois les erreurs corrigées


Vous pouvez aussi 

Juste désactiver et arrêter le Service de publication sur le Web (Cela ferme IIS pour toujours) - - - (Vous devez utiliser Courir du point de départ dans les fenêtres):

sc config w3svc start= disabled
net stop w3svc

Si vous ne voulez pas qu'il soit désactivé, mais plutôt manuel, remplacez désactivé par la demande (ne supprimez pas d'espace).


115
2018-06-21 05:55



Si vous utilisez Windows 10, comme je le suis, et le port est occupé par Microsoft-IIS / 10.0, modifiez le lignes 62 et 63, du httpd.conf, de:

Listen 0.0.0.0:80
Listen [::0]:80

À:

Listen 0.0.0.0:8080
Listen [::0]:8080

Comme les gens ici ont suggéré.

Et aussi, changez le ligne 221, de:

ServerName localhost:80

À:

ServerName localhost:8080

Maintenant, votre hôte sera disponible à http: // localhost: 8080 /.


15
2017-11-05 18:42



  1. Aller à Control Panel > Administrative Tools > Services ou tapez simplement services.msc en cours pour ouvrir une liste de tous les services Windows.
  2. Trouver World Wide Web Publishing Service et stop il. (Si vous voulez le désactiver de façon permanente, vous pouvez modifier son type de démarrage à partir de automatically à disabled).

C'est tout


8
2018-05-30 12:10



Cela pourrait également être un problème de port 80 utilisé par "Web Agent Deployment Agent Service". vous pouvez l'arrêter des outils d'administration-> services et libérer ce port. comme montré ici


6
2017-11-13 07:22



Oui, vous pouvez simplement changer le port en un nombre quelconque. Par exemple, changer Listen 80 à Listen 81 dans le httpd.conf fichier. Maintenant essayez avec http://localhost:81 et il va répondre sur le port 81 !!


5
2017-09-16 04:38



aller au service et arrêter le "Service de publication sur le Web" après le redémarrage du serveur wamp. après cela commence le "Service de publication sur le Web"


5
2018-02-12 06:10



Après avoir désinstallé IIS sur Windows 7, j'ai continué à disposer d'une page d'accueil IIS. La solution consistait à vider le cache de mes navigateurs Web. Cela fonctionne très bien maintenant. Je n'ai rien changé d'autre. Désolé pour mon anglais, si ce n'est pas parfait.

Cordialement


3
2017-08-27 17:48