Question Comment puis-je remédier à la "Le point de rupture ne sera pas actuellement touché. Aucun symbole n'a été chargé pour ce document. "Warning?


Application de bureau C # sur l'édition express. Travaillé alors n'a pas fonctionné 5 secondes plus tard.

J'ai essayé ce qui suit.

  • Vérifiez que la configuration du débogage, l'indicateur de débogage et les informations de débogage complètes sont définis sur tous les assemblys.
  • Supprimez tous les dossiers bin et obj et toutes les DLL liées au projet de ma machine entière.
  • Recréer des projets causant le problème à partir de zéro.
  • Redémarrez.

J'ai deux projets WinForms dans la solution. L'un d'entre eux charge l'information de débogage, l'autre ne le fait pas. Ils se réfèrent tous deux à l'assemblage que j'essaie d'obtenir des informations de débogage exactement de la même manière dans le fichier de projet. Des idées?


Je veux ajouter ici, surtout pour moi-même quand je reviens sur cette question, que les symboles ne sont pas chargés tant que l'assemblage n'est pas chargé et que l'assemblage n'est pas chargé tant que cela n'est pas nécessaire. Si le point d'arrêt est dans une bibliothèque qui n'est utilisée que dans une fonction de votre assembly principal, les symboles ne seront pas chargés (et le point d'arrêt sera affiché comme n'étant pas touché) jusqu'à ce que cette fonction soit appelée.


1141


origine


Réponses:


Commencer le débogage, dès que vous arrivez à un point d'arrêt ou utilisé Debug > Break All, utilisation Debug > Windows > Modules. Vous verrez une liste de tous les assemblys qui sont chargés dans le processus. Localisez celui pour lequel vous souhaitez obtenir des informations de débogage. Cliquez avec le bouton droit sur celui-ci et sélectionnez Informations de chargement de symbole. Vous obtiendrez une boîte de dialogue qui répertorie tous les répertoires où il a recherché le fichier .pdb pour l'assembly. Vérifiez cette liste par rapport à l'emplacement réel .pdb. Assurez-vous qu'il ne trouve pas un ancien.

Dans les projets normaux, l'assembly et son fichier .pdb doivent toujours avoir été copiés par l'EDI dans le même dossier que votre fichier .exe. Le dossier bin \ Debug de votre projet. Assurez-vous d'en avoir retiré un du GAC si vous avez joué avec.


841



Essayez d'abord de reconstruire votre projet en cliquant avec le bouton droit de la souris sur le projet> Reconstruire Si cela ne fonctionne pas, essayez un nettoyage du projet (clic droit sur le projet> clean)

Si cela ne fonctionne pas, vérifiez ceci:

  1. Clic droit sur votre souris projet
  2. sélectionner [Propriétés]
  3. sélectionnez le [Construire] languette
  4. assure-toi [Définir la constante DEBUG] et [Définir la constante TRACE] sont vérifiés
  5. Clique le [Avancée] bouton au bas de la page à onglet Générer
  6. Sois sûr que [Les informations de débogage:] est réglé sur [plein]
  7. Cliquez sur [OK] et reconstruire le projet ;-)

(l'étape 6 génère les fichiers .pdb, ce sont les symboles de débogage)


264



Juste quelque chose de simple à essayer - vous l'avez peut-être déjà essayé. Cliquez avec le bouton droit sur la solution dans l'explorateur de solution, cliquez sur "clean solution", ceci supprime tous les fichiers compilés et temporaires associés à une solution.

Faites une reconstruction de la solution et essayez de déboguer à nouveau.

J'ai également eu des problèmes avec des points d'arrêt multiples projets dans une solution - certains compilés en tant que x86, certains en tant que x64.


236



Désactivez l'option "Just My Code" dans les paramètres Debug / General.


178



Croix affichant ce correctif de Hans K que j'ai trouvé sur le fil similaire >> ICI <<:

Faites un clic droit sur la solution -> Propriétés

Regardez sous Common Properties -> Startup Project

Sélectionnez plusieurs projets de démarrage

sélectionnez Démarrer l'action sur les projets que vous devez déboguer.


123



La réponse choisie m'a conduit à résoudre mon problème. Mais j'ai besoin de faire quelques choses de plus:

Même avec "Debug" sélectionné dans la liste déroulante:

enter image description here

Et dans le projet Propriétés> Construire:

enter image description here

Visual Studio ne chargeait pas de symboles dans un projet spécifique. Donc, dans cette liste déroulante, je sélectionne "Configuration Manager" et j'ai vu que les paramètres de mon projet Web étaient incorrects:

enter image description here

enter image description here

Ensuite, j'ai mis cela à "Debug" et il a commencé à générer le .pdb fichier. MAIS Je dois copier manuellement le PDB et le DLL et mettre dans le dossier que VS regardait (ici est où la réponse choisie m'a aidé):

enter image description here


45



Debug > Windows > Modules pour voir quels modules étaient chargés me mettre dans la bonne direction.

Dans mon cas, IIS Express semblait charger une DLL différente des fichiers temporaires ASP.NET.

La solution?

  1. Parcourir pour C:\Users\<YOUR USER>\AppData\Local\Temp\Temporary ASP.NET Files\vs
  2. Supprimez tout dans ce répertoire!

36



J'ai été en mesure de corriger l'erreur en définissant simplement l'option dans l'option 'Fixer au processus' sur 'Déterminer automatiquement le type de code à déboguer' comme indiqué dans la capture d'écran ci-jointe.

Suivez simplement les étapes ci-dessous:

  • Aller à Déboguer à partir de la barre de menu
  • Cliquer sur Attacher au processus 
  • Près de Attacher à option, cliquez sur Sélectionner bouton
  • le Sélectionner le type de code la fenêtre apparaîtra
  • Maintenant, sélectionnez l'option Déterminer automatiquement le type de code à déboguer et cliquez sur le bouton OK.

Fixed Debugging Error


34



Parfois, même si cela vous donne cette erreur, le breakpoint est toujours touché, alors ignorez simplement l'erreur. Cela arrive assez souvent dans le Views d'un MVC web app.


30



Vérifiez si votre fichier .pbd est manquant dans votre dossier bin / Debug. Si c'est alors allez dans "Propriétés" de votre projet, sélectionnez "Construire" puis "Avancé" en bas. Choisissez "full" sous "Informations de débogage" dans la nouvelle fenêtre qui apparaît. C'était mon problème et résolu pour moi.

Showing where to find the setting


27



Dans mon cas, "Optimize Code" a été vérifié dans mes propriétés de projet. Cela a amené VS à voir mon assembly comme "pas mon code", et à son tour, il n'a pas chargé de symboles pour cela.

La solution était de décocher cela. Location of Optimize Code checkbox


22