Question Erreur intelliJ IDEA 13: sélectionnez le SDK Android


J'ai installé Android SDK 22.3 et JDK 1.7 update 21 sur Win7 x64. Maintenant, j'ai créé un projet d'application Android vide en utilisant intelliJ 13.0.1 (utilisez également Emulator comme périphérique cible) et tentez de construire le projet, mais rencontrez le problème. 'Error: Please select Android SDK'.

Donc je choisis Emulator comme le Target Device, mais je ne pouvais pas sélectionner mon AVD, car il y a un Error: Cannot find any configured Android SDK.

Dans la structure du projet, la plate-forme Android 4.4.2 apparaît clairement en tant que SDK de projet. Donc, je suis totalement confus, je ne sais pas comment résoudre le problème.

ps. Je mettais à jour intelliJ 12.1.2 à intelliJ 13.0.1, et tous les paramètres ont été automatiquement hérités de 12.1.2 lors du lancement de 13.0.1, mais il semble que tous les paramètres n’ont pas été exactement copiés sur 13.0.1, ce qui est inattendu.

à votre santé


63
2018-01-12 01:37


origine


Réponses:


Mon problème: "S'il vous plaît sélectionnez Android SDK", mais tout va bien :( -> Je pense que l'un des fichiers IntelliJ a été planté (après l'écran bleu de la mort)

Ma résolution:

Fichier -> Paramètres -> SDK Android -> Emplacement du SDK Android Édition -> Suivant, Suivant (le SDK Android est à jour.), Terminé

... et le fichier écrasé a été réparé!


133
2018-03-21 13:53



J'ai rencontré cette erreur après avoir installé Intellij IDEA Ultimate 14.1 et ouvert un projet Android existant que j'avais créé avec Android Studio. Il s'est avéré que je devais simplement ajouter le SDK Android à ma liste de SDK et corriger les paramètres du SDK de projet / module. Voici comment je l'ai fait:

Aller à File -> Project Structure. Cliquez sur l'onglet Projet sous Paramètres du projet. Sous Project SDK, cliquez sur New -> Android SDK.

Adding new Android SDK

Sélectionnez maintenant le répertoire existant pour votre SDK Android. Dans mon cas, c'était dans ce dossier:

C:\Users\<windows username>\AppData\Local\Android\android-sdk

Cliquez sur OK. Un menu apparaît vous demandant de définir la cible Java SDK + Build. Vous pouvez soit les modifier, soit les laisser par défaut et appuyer sur Ok. Vous devriez maintenant voir "Plate-forme Android API XX" dans le menu déroulant Project SDK. Cliquez sur Appliquer en bas. Ensuite, allez à l'onglet Modules sous Paramètres du projet et cliquez sur les dossiers dans la liste des modules.

Module List

Pour chaque dossier, accédez à l'onglet Dépendances et remplacez le SDK du module par le nouveau SDK Android, puis cliquez sur Appliquer. Cliquez ensuite sur Ok pour fermer la boîte de dialogue Structure du projet.

Après avoir fait ce qui précède, mon projet a été corrigé.


64
2018-05-31 05:01



J'ai eu le même problème une fois. tout semble correct. Je redémarre, supprime et invalide le cache du studio Android, reconstruit, propre et rien changé. Il est finalement résolu en cliquant sur Projet de synchronisation avec les fichiers Gradle bouton dans le studio Android 3.0

Sync Project with Gradle Files button


44
2017-11-26 08:24



Supprimez tous les SDK Android d'Intellij et ajoutez-les à nouveau.

Pour faire cette structure de projet ouverte, dans le volet SDK, supprimez tous les SDK Android, cliquez sur OK. ouvrir la structure du projet et les ajouter à nouveau.


32
2017-08-30 14:49



Si vous ne pouvez pas compiler un projet et que vous avez ce message:

enter image description here

Aller à Fichier -> Structure du projet, ensuite aller à Modules section et sélectionnez votre application de module, puis sélectionnez un Compiler la version Sdk et un Version des outils de construction après cela, cliquez dans D'accord.

enter image description here

Attendez jusqu'à ce que gradle se synchronise et soit prêt!


5
2017-12-12 22:49



J'ai fait face au problème dans IntelliJ Idea 14 en fait. Mon projet fonctionnait bien sur Android Studio. J'ai décidé de continuer le développement sur l'idée d'IntelliJ. Après l'importation du projet, je n'ai pas réussi à l'exécuter et j'ai reçu un message d'erreur similaire dans la boîte de dialogue Modifier la configuration. Sur la base de ce que @Ali a dit, j'ai supprimé tous mes SDK et les ai réinstallés, mais cela n'a pas fonctionné.

J'ai ouvert "Structure du projet"> "Paramètres de la plate-forme"> SDK. J'ai trouvé "Build target" de "Android API 21 Platform" n'est pas défini. Par régler sur l'un de mes derniers SDK, le problème a été résolu et j'ai pu exécuter le projet sans problème.


3
2018-02-25 03:58



  1. Aller à la structure du projet (Ctrl + Alt + Maj + S) -> Paramètres Platforn -> SDK -> appuyer sur l'icône "Plus"
  2. Sélectionnez "Android SDK" et entrez le chemin du SDK (par exemple: C: \ Program Files (x86) \ Android \ android-sdk)
  3. Appliquer ou bouton OK
  4. Soyez heureux

2
2017-07-20 12:24



dans Android 3.1.1, nous ne pouvons pas trouver le projet de synchronisation dans les outils alors C:\Users\AndroidStudioProjects\projectname\.idea\libraries supprimer les fichiers des bibliothèques et synchroniser à nouveau


2
2018-05-21 10:37



J'ai eu le même problème que lorsque j'ai également mis à jour l'intellij Idea 12 à 13. Dans ma situation, la cible Build de mon SDK Android n'était pas reconnue correctement. Même si j'ai choisi Android 2.2 et cliqué sur Appliquer et OK, le message "Non défini" s'affiche à nouveau lorsque j'ai rouvert la boîte de dialogue de structure du projet.

Ensuite, j'ai choisi une autre version, Android 4.0 cette fois, cliqué sur Appliquer, puis choisi à nouveau Android 2.2, cliqué sur Appliquer. Cela a fonctionné pour moi.


1
2017-08-01 02:57



Peut-être pas une solution si commune mais pour moi redémarrer l'IDE a bien fonctionné. J'utilise Android Studio 2.2.3.


1
2018-02-28 09:31