Question Erreur de configuration: Cette section de configuration ne peut pas être utilisée sur ce chemin


J'ai rencontré une erreur lors du déploiement d'un site sur un serveur. Lorsque j'essaie de charger la page d'accueil ou d'accéder à l'authentification sur le nouveau site dans IIS, j'obtiens l'erreur suivante:

Erreur de configuration: Cette section de configuration ne peut pas être utilisée pour ce chemin.   Cela se produit lorsque la section est verrouillée au niveau parent. Le verrouillage est   soit par défaut (overrideModeDefault = "Deny"), soit défini explicitement par un   tag de localisation avec overrideMode = "Refuser" ou l'héritage   allowOverride = "false".

Plus de détails peuvent être trouvés ici, dans Scénario 7 correspond à mon code d'erreur hexadécimal.

La solution donnée sur le site lié ci-dessus est de définir Permettre pour overrideModeDefault dans la section mentionnée dans mon erreur, dans le applicationHost.config fichier. Dans mon cas, sous Sécurité dans system.webServer. Mais si je regarde le applicationHost.config sur mon ordinateur local, où le site est déjà correctement déployé, cette section est définie sur Nier.

Si cette solution est correcte, comment mon instance locale fonctionne-t-elle correctement? web.config? Selon mon applicationHost.config, cette section devrait être verrouillée, mais ce n'est pas le cas. Je préférerais ne pas changer le applicationHost.config fichier, car de nombreux autres sites sont en cours d'exécution sur ce serveur. Y a-t-il une autre solution?


1442
2018-03-20 21:07


origine


Réponses:


J'ai eu le même problème. Je ne me souviens pas où je l'ai trouvé sur le web, mais voici ce que j'ai fait:

  • Cliquez sur "Démarrer le bouton"
  • dans la zone de recherche, entrez "Activer ou désactiver les fonctionnalités Windows"
  • dans la fenêtre des fonctionnalités, cliquez sur: "Internet Information Services"
  • Cliquez sur: "World Wide Web Services"
  • Cliquez sur: "Fonctionnalités de développement d'applications"
  • Cochez (activez) les fonctionnalités. J'ai vérifié tout sauf CGI.

BTW, j'utilise Windows 7.


2759
2017-10-12 22:06



Vous pouvez également utiliser le Gestionnaire IIS pour modifier ces paramètres.

Soin de ceci Apprenez l'article IIS:

En utilisant le Délégation de fonctionnalités à partir de la racine de IIS:

Feature delegation icon in IIS Manager

Vous pouvez ensuite contrôler chacune des autorisations de lecture / écriture au niveau machine, ce qui vous overrideMode = "Refuser" les erreurs.

Example use of Feature Delegation


302
2017-09-09 21:28



Pour Windows Server 2012 et IIS 8, la procédure est similaire.

le Web Server (IIS) et Application Server devrait être installé, et vous devriez également avoir l'option Web Server (IIS) Support en dessous de Application Server.

Windows Server 2012 and IIS 8 Requirements for MVC


165
2018-01-30 01:01



Accédez à "C: \ Windows \ System32 \ inetsrv \ config" (vous aurez besoin des droits d'administrateur ici) Ouvrez applicationHost.config

Remarque: Dans IISExpress et Visual Studio 2015, applicationHost.config est stocké dans $(solutionDir).vs\config\applicationhost.config 

Trouvez la section qui apparaissait dans la partie "source de la config" de la page du message d'erreur. Pour moi, cela a typiquement été "modules" ou "handlers"

Changer la overrideModeDefault attribut à être Allow

Donc, toute la ligne ressemble maintenant à:

<section name="modules" allowDefinition="MachineToApplication" overrideModeDefault="Allow" />

Après avoir enregistré le fichier, la page s'est bien chargée dans mon navigateur.

Attention: Modification de applicationHost.config sous Windows 64 bits


110
2018-04-30 20:22



Vous devez déverrouiller les gestionnaires. Cela peut être fait en utilisant la commande cmd suivante:

%windir%\system32\inetsrv\appcmd.exe unlock config -section:system.webServer/handlers

Peut-être une autre information pour les personnes qui obtiennent cette erreur sur IIS 8, dans mon cas était sur la plate-forme Microsoft Server 2012. J'ai passé quelques heures à me battre avec d'autres erreurs qui ont éclaté après l'exécution de appcmd. À la fin, j'ai été en mesure de résoudre le problème en supprimant le rôle de serveur Web et en l'installant à nouveau.


58
2017-12-06 21:17



Selon ma réponse à ce problème similaire;

Essayez de déverrouiller les paramètres de configuration IIS pertinents au niveau du serveur, comme suit:

  1. Ouvrir Gestionnaire IIS
  2. Sélectionnez le serveur dans le volet Connexions
  3. Ouvrir Éditeur de configuration dans le volet principal
  4. Dans la liste déroulante Sections, sélectionnez la section à déverrouiller, par ex. system.webServer> defaultPath
  5. Cliquez sur Débloquer l'attribut dans le volet de droite
  6. Répétez pour tous les autres paramètres dont vous avez besoin pour déverrouiller
  7. Redémarrer IIS (facultatif) - Sélectionnez le serveur dans le volet Connexions, cliquez sur Redémarrer dans le volet Actions

27
2017-09-06 08:16



J'avais besoin d'exécuter ces deux commandes de et invite de commande élevée:

%windir%/system32/inetsrv/appcmd unlock config /section:anonymousAuthentication

%windir%/system32/inetsrv/appcmd unlock config -section:windowsAuthentication

24
2017-11-18 11:22



Sur Windows Server 2012 avec IIS 8 J'ai résolu cela en permettant ASP.NET 4.5 fonctionnalité:

enter image description here

et ensuite La réponse de Ken.


23
2018-02-10 17:56



Pour Win 10 (Probablement travaillera sur d'autres versions de Windows aussi.)

1. Ouvert "Activer ou désactiver des fonctionnalités Windows"par: WinKey + R =>" optionalfeatures "=> OK

enter image description here

  1. Activer ces fonctionnalités sous "Fonctionnalités de développement d'applications "

enter image description here


21
2018-02-23 09:40