Question Trouver la version d'un paquet npm installé


Comment trouver la version d'un node.js / npm installé paquet?

Cela imprime la version de npm elle-même:

npm -v <package-name>

Cela imprime une erreur cryptique:

npm version <package-name>

Ceci imprime la version du paquet sur le registre (c'est-à-dire la dernière version disponible):

npm view <package-name> version

Comment puis-je obtenir le version installée?


1573
2018-06-10 20:36


origine


Réponses:


npm list pour les forfaits locaux ou npm list -g pour les packages installés dans le monde entier.

Vous pouvez trouver la version d'un paquet spécifique en passant son nom en argument. Par exemple, npm list grunt aura pour résultat:

projectName@projectVersion /path/to/project/folder
└── grunt@0.4.1

Alternativement, vous pouvez simplement courir npm list sans passer un nom de paquet en argument pour voir les versions de tous vos paquets:

├─┬ cli-color@0.1.6 
│ └── es5-ext@0.7.1 
├── coffee-script@1.3.3 
├── less@1.3.0 
├─┬ sentry@0.1.2 
│ ├── file@0.2.1 
│ └── underscore@1.3.3 
└── uglify-js@1.2.6 

1930
2018-06-11 19:13



Un autre moyen rapide de découvrir quels paquets sont installés localement et sans leurs dépendances est d'utiliser:

npm list --depth=0

Ce qui vous donne quelque chose comme

├── bower@0.8.6
├── grunt@0.4.1
├── grunt-bower-requirejs@0.4.3
├── grunt-contrib-clean@0.4.1
├── grunt-contrib-coffee@0.7.0
├── grunt-contrib-copy@0.4.1
├── grunt-contrib-imagemin@0.1.4
├── grunt-contrib-jshint@0.1.1
├── grunt-contrib-livereload@0.1.2
├── grunt-contrib-requirejs@0.4.1
├── grunt-regarde@0.1.1
└── grunt-svgmin@0.1.0

De toute évidence, la même chose peut être fait globalement avec npm list -g --depth=0.

Cette méthode est plus claire si vous avez installé beaucoup de paquets.

Pour savoir quels paquets doivent être mis à jour, vous pouvez utiliser npm outdated -g --depth=0.


705
2018-05-23 01:50



npm view <package> version - renvoie la dernière version disponible sur le package.

npm list --depth=0 - renvoie les versions de tous les modules installés sans dépendances.

npm list - renvoie les versions de tous les modules et dépendances.

Et enfin pour obtenir la version de noeud: node -v


164
2017-07-01 03:03



npm info YOUR_PACKAGE version

par exemple.

npm info grunt version
0.4.5

70
2018-06-24 03:21



Je viens d'utiliser npm list | grep <package name> et ça a bien fonctionné

Sur les fenêtres, exécutez:

npm list | find <package name>

Dans PowerShell, exécutez:

npm list | sls <package name>


38
2018-01-27 12:39



De la racine du paquet faire:

node -p "require('./package.json').version"

MODIFIER: (donc vous devez cd dans le répertoire personnel du module si vous n'y êtes pas déjà. Si vous avez installé le module avec npm install, alors il sera sous node_modules/<module_name>)

EDIT 2: mis à jour selon la réponse de @ jeff-dickey


27
2017-09-30 11:57



Vous pouvez utiliser Vue npm version [module], info npm [module] version, Version npm show [module] ou npm v [module] version pour vérifier la version sur un module NPM installé.

Supposons que ma version de module grunt est la 0.4.5:

npm view grunt version => 0.4.5
npm info grunt version => 0.4.5
npm show grunt version => 0.4.5
npm v grunt version    => 0.4.5

13
2017-11-12 15:53