Question Le terme 'Activer-Migrations' n'est pas reconnu en premier


J'essaie de courir pour la première fois dans ma nouvelle application mvc 4     PM> Activer les migrations - Activer les migrations automatiques

Je reçois:

Enable-Migrations : The term 'Enable-Migrations' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of the name, or 
if a path was included, verify that the path is correct and try again.
At line:1 char:1
+ Enable-Migrations –EnableAutomaticMigrations

Qu'est-ce que je rate? J'ai installé e.f 5.


13
2018-06-28 10:53


origine


Réponses:


Essayez de taper dans la console du gestionnaire de packages:

Install-Package EntityFramework -IncludePrerelease

puis redémarrez Visual Studio.


14
2018-04-18 13:07



Tout d'abord, "Install-Package EntityFramework -IncludePrerelease", puis Redémarrer Visual Studio en tant qu'administrateur ont fonctionné pour moi ensemble.

[Référer ceci]: Package Manager Console Enable-Migrations CommandNotFoundException uniquement dans un projet VS spécifique


1
2017-08-04 12:30



J'ai installé le framework (5.x) et j'ai réessayé d'exécuter les mêmes commandes après avoir été exécuté en mode admin. Cela a résolu le problème - bien étrange cependant.


0
2018-03-20 09:17



Vous devez vous assurer que vous n'avez pas de crochets "[" dans votre répertoire de chemin d'accès du projet. Apparemment, VS 2013 n'est pas satisfait des dossiers de projets nommés avec des crochets.


0
2018-05-18 13:50