Question IDEA: javac: la version source 1.7 nécessite une version cible 1.7


Lors de l'exécution d'un test JUnit, en utilisant IntelliJ IDEA, je reçois

enter image description here

Comment puis-je corriger cela?

  • Utilisation du SDK 1.7
  • Le niveau de langue du module est de 1,7

Maven fonctionne bien. (C'est pourquoi je crois que cela dans la question de configuration IDEA)


415
2017-10-15 16:55


origine


Réponses:


Vous avez probablement des options de compilateur incorrectes importées de Maven ici:

compiler options

Vérifiez également le projet et le module bytecode (cible) les paramètres de version décrits sur la capture d'écran.

D'autres endroits où le la source le niveau de langue est configuré:

  • Structure du projet | Projet

project

  • Structure du projet | Modules (vérifiez chaque module) | Sources

sources

Maven niveau de langue par défaut est 1,5 (5.0), vous verrez cette version comme le niveau de langue du module sur la capture d'écran ci-dessus.

Cela peut être changé en utilisant maven-compiler-plugin configuration à l'intérieur pom.xml:

<project>
  [...]
  <build>
    [...]
    <plugins>
      <plugin>
        <groupId>org.apache.maven.plugins</groupId>
        <artifactId>maven-compiler-plugin</artifactId>
        <configuration>
          <source>1.8</source>
          <target>1.8</target>
        </configuration>
      </plugin>
    </plugins>
    [...]
  </build>
  [...]
</project>

ou

<project>
  [...]
  <properties>
    <maven.compiler.source>1.8</maven.compiler.source>
    <maven.compiler.target>1.8</maven.compiler.target>
  </properties>
  [...]
</project>

IntelliJ IDEA respectera ce paramètre après que vous Réimporter le projet Maven dans le Projets Maven fenêtre d'outils:

reimport


576
2017-10-15 17:26



IntelliJ 15, 2016 et 2017

Similaire à ce qui est discuté ci-dessous pour IntelliJ 13 et 14, mais avec un niveau supplémentaire dans le panneau Paramètres / Préférences: Paramètres > Construire, exécuter, déployer > Compilateur > Compilateur Java.

enter image description here

IntelliJ 13 & 14

Dans IntelliJ 13 et 14, vérifiez les Paramètres> Compilateur> Compilateur Java L'interface utilisateur vous permet de ne pas cibler une version de bytecode différente dans votre module.

enter image description here


350
2018-01-18 21:02



Dans IntelliJ IDEA 14.1 la "version du bytecode cible" se trouve à un autre endroit.

Le changement suivant a fonctionné pour moi:

Fichier> Paramètres ...> Créer, exécuter, déployer> Compilateur> Java Compiler : changement Version de bytecode cible de 1,5 à 1,8

enter image description here

enter image description here


61
2018-04-07 22:12



Avez-vous regardé votre configuration de construction, il devrait aimer cela si vous utilisez maven 3 et JDK 7

<build>
    <finalName>SpringApp</finalName>
    <plugins>
        <plugin>
            <artifactId>maven-compiler-plugin</artifactId>
            <configuration>
                <source>1.7</source>
                <target>1.7</target>
            </configuration>
        </plugin>
        ...
    </plugins>
    ...
</build>

40
2017-08-25 11:29



Je suis tombé sur ceci et le correctif était d'aller dans Paramètres du projet> Modules> cliquer sur le module particulier> onglet Dépendances. J'ai remarqué que le module SDK était toujours réglé sur 1.6, je l'ai changé à 1.7 et ça a fonctionné.


22
2017-12-13 04:20



J'ai trouvé les options requises ('version de bytecode cible') dans settings> compilateur> compilateur java dans mon cas (idée intelij 12.1.3)


13
2018-06-15 10:57



Modifiez le fichier de configuration du compilateur du projet dans le chemin suivant et remplacez la cible par 1.7:

/project/.idea/compiler.xml

<bytecodeTargetLevel>
  <module name="project-name" target="1.7" />
</bytecodeTargetLevel>

9
2018-06-08 14:14



Je l'ai résolu en définissant le champ vide:

Paramètres> Compilateur> Compilateur Java> Version du bytecode du projet

Than IntelliJ utilise la version par défaut de JDK.


5
2017-12-20 12:08



D'un moment à l'autre j'ai aussi eu cette erreur sans raison claire. J'ai changé toutes sortes de paramètres sur le compilateur / module etc. Mais à la fin je viens de recréer le projet IntelliJ en réimportant le projet Maven et le problème a été résolu. Je pense que c'est un bug.

IntelliJ 12 129,961


4
2017-07-20 09:31