Question Aucun compilateur n'est fourni dans cet environnement. Peut-être que vous utilisez un JRE plutôt qu'un JDK?


Je compile un projet dans Eclipse en utilisant m2eclipse. J'ai défini le chemin JDK dans Eclipse comme ceci:

Windows-->preferences-->installed jres--> jdk1.7.xx  path

Mais ceci montre une erreur

[ERROR] COMPILATION ERROR :
[INFO] -------------------------------------------------------------
[ERROR] No compiler is provided in this environment. Perhaps you are running on a JRE    rather than a JDK?
[INFO] 1 error
[INFO] -------------------------------------------------------------
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 1.424s
[INFO] Finished at: Tue Oct 29 15:21:01 IST 2013
[INFO] Final Memory: 5M/15M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-   plugin:3.1:compile (default-compile) on project TEST-WEB: Compilation failure
[ERROR] No compiler is provided in this environment. Perhaps you are running on a JRE rather than a JDK?

456
2017-10-29 10:11


origine


Réponses:


  1. Sur votre IDE Eclipse, allez dans Fenêtre > Préférences > Java > JRE installés > et vérifiez votre JRE installés. Vous devriez avoir une entrée avec un JDK là.
  2. Sélectionnez l'Execution Env comme indiqué ci-dessous. Cliquez sur D'accord
  3. alors Clic-droit sur votre projet -> Maven -> Mettre le projet

En outre, vous devrez peut-être modifier Maven JRE (voir réponse @ jlars62) qui est la suivante. Goto Run -> Run Configurations, en sélectionnant Maven Build I (depuis le panneau de gauche). Ensuite, j'ai cliqué sur l'onglet JRE et sélectionné l'option Workspace par défaut JRE

enter image description here


707
2018-01-22 09:34



Pour moi, c'est exactement ce que se plaint la maven d'éclipse

enter image description here

Donc, j'appuie Edit bouton et changer de chemin vers le dossier JDK, puis nettoyer le projet et tout commence à fonctionner


97
2018-04-25 09:13



Pour moi, rien n'a fonctionné jusqu'à ce que je modifie mon fichier pom.xml:

<build>
...
    <plugins>
    ...
        <plugin>
            <artifactId>maven-compiler-plugin</artifactId>
            <version>3.1</version>
            <configuration>
                <fork>true</fork>
                <executable>C:\Program Files\Java\jdk1.7.0_45\bin\javac.exe</executable>
            </configuration>
        </plugin>
    </plugins>
</build>

Autres notes

Je pouvais voir que m2e s'exécutait dans un JRE, pas le JDK. Rien de ce que j'ai fait n'a changé, y compris en ajoutant ceci à l'eclipse.ini:

-vm
C:\Program Files\Java\jdk1.7.0_45\bin\javaw.exe

Au final, je n'ai jamais réussi à exécuter m2e dans un JDK, mais le fait de configurer explicitement le compilateur Java (comme ci-dessus) a fait l'affaire.


85
2018-01-01 00:32



  1. Met le JAVA_HOME variable d'environnement dans le dossier racine JDK - requis si vous exécutez la ligne de commande ou maven (google pour cette variable)
  2. Dans les propriétés du projet dans la section Compilateur Java, sélectionnez JDK requis - si vous exécutez directement depuis eclipse

61
2017-10-29 10:15



Dans mon cas, cela a été résolu en faisant ceci: 

Accédez à votre 'Configuration d'exécution' et configurez votre JRE à un JDK.

Select the right JDK for your Runtime

Select default JRE

J'ai copié la réponse juste au cas où il est supprimé pour une raison quelconque, mais la source est ici


30
2018-04-05 21:31



J'avais cette erreur en essayant de faire une compilation de maven à partir de l'éclipse.

Pour moi, la réponse allait Run -> Run Configurations, en sélectionnant le Maven Build Je courais (à partir du panneau de gauche). Ensuite, j'ai cliqué sur le JRE onglet et sélectionné l'option Workspace default JRE


29
2017-09-02 21:22



Allez dans Windows -> Préférences -> Java -> JRE installés

peut être jre est déjà ajouté enter image description here

cliquez sur Ajouter -> VM standard -> Suivant -> Répertoire

et naviguez pour le JDK dans mon cas, le chemin était C:\Program Files\Java\jdk1.8.0_111

puis cliquez sur Terminer.

vous verrez une fenêtre comme celle-cienter image description here

sélectionnez JDK -> Appliquer -> Ok

Et vous avez terminé.


21
2017-12-06 16:43