Question Le JavaScript de Bootstrap nécessite la version 1.9.1 ou supérieure de jQuery, mais inférieure à la version 3


introduction

Je travaille avec le framework bootstrap. Je travaille actuellement sur les "Onglets Bootstrap" (hide / show). J'utilise quelque chose comme bootstrap version 3 et jquery version 3.0.2.

Problème

Mes onglets ne fonctionnent pas, sauf si je charge jquery de version inférieure à 1.6. Mais alors ajax pose problème avec jquery inférieur à 1.6. La console Chrome me donne cette erreur.

bootstrap.min.js: 6 Erreur non détectée: le JavaScript de Bootstrap nécessite   jQuery version 1.9.1 ou supérieure, mais inférieure à la version 3

J'ai essayé différentes techniques de repli mais je n'ai pas pu implémenter correctement.

Je suis coincé ici pendant 2 jours, si quelqu'un a une idée ou une référence, s'il-vous-plait, aidez-moi. Merci pour votre temps.


16
2018-06-21 06:10


origine


Réponses:


Actuellement, Bootstrap 3.x ne supporte pas jQuery 3.x comme indiqué ici: https://github.com/twbs/bootstrap/issues/16834

Le problème est causé par:

jQuery 3 est plus strict que jQuery 2. Il est comme XHTML et HTML.   La compatibilité ascendante est préservée et le code ne ressemble pas à un désordre.   Si je ne me trompe pas, il suffit de remplacer show () et hide ()   fonctions avec .css ('display', '') ou addClass ('hidden') et corrige un   selector dans alert.js (QUnit échoue sur cette ligne car $ ('#') est   invalide dans jQuery 3)

Il est corrigé dans la version Bootstrap 3.3.7: https://github.com/twbs/bootstrap/issues/16834#issuecomment-225039913


11
2018-06-21 06:26



La dernière version actuelle de Bootstrap (3.3.7) supporte maintenant jQuery 3+, selon les commentaires des développeurs ici https://github.com/twbs/bootstrap/issues/16834.


7
2017-10-25 09:42



Ce qui a résolu mon problème est de charger la version inférieure de jquery avant bootstrap.js, puis de charger la version supérieure de jquery après bootstrap.js pour résoudre les conflits.

<script src="http://ajax.googleapis.com/ajax/libs/jquery/1.10.2/jquery.min.js"></script>
<script src="~/App_Theme/bootstrap/js/bootstrap.min.js"></script>
<script>
    var $j = jQuery.noConflict();
</script>

<script src="http://ajax.googleapis.com/ajax/libs/jquery/3.0.0/jquery.min.js"></script>
<script>
    var $ = jQuery.noConflict();
</script>

3
2017-07-22 04:59



Si vous utilisez Bower pour gérer vos paquets javascript, pour exclure jquery 3.0, vous devez spécifier la version de jquery comme:

"jquery": "^2.2"

dans ton bower.json.

le bower.json de jquery-ui le paquet a une ligne suivante:

"jquery": ">=1.6"

À cause de cela, Bower installe la dernière version de jQuery, ce qui pose problème.

Notez que jQuery 3.0 est disponible à partir du 9 juin 2016.


3
2018-06-21 09:25



Quant à moi, tout est simple. Il s'agit de fichiers de liens de file d'attente. Je dois déplacer des liens comme ceci:

<head>
     <script src="js/jquery1.9.1.js"></script>
     <script src="js/bootstrap.js"> </script>       
</head>

Après tout, cela fonctionne mieux.


1
2017-08-05 23:29



J'ai eu le même problème et je n'ai pas jquery 1.8.2 dans mes pages web.Je résous mon problème en changeant la version de jquery dans packages.config

changement

  <package id="AspNet.ScriptManager.jQuery" version="1.8.2" targetFramework="net45" />
 <package id="jQuery" version="1.8.2" targetFramework="net45" />

à

<package id="AspNet.ScriptManager.jQuery" version="2.1.4" targetFramework="net45" />
 <package id="jQuery" version="2.1.4" targetFramework="net45" />

ma version jquery est 2.1.4


1
2017-11-09 16:08



J'avais donc la nouvelle version de Bootstrap mais pour une raison quelconque, la version min était toujours l'ancienne version qui ne supportait pas le JQuery 3. J'ai enlevé le bootstrap minifié JS puis reminifié le nouveau Bootstrap.js et déployé et le problème a disparu.


1
2018-04-19 21:23