Question La complétion du code Eclipse / Java ne fonctionne pas


J'ai téléchargé, décompressé et configuré Eclipse 3.4.2 avec quelques plugins (notables, EPIC, Clearcase, QuantumDB, MisterQ).

Maintenant, je trouve que lorsque je suis en train d'éditer des projets Java, l'achèvement du code ne fonctionne pas. Si je tape String. et appuyez ctrl+espace une fenêtre contextuelle affiche "Aucune proposition par défaut" et la barre d'état en bas affiche "Aucun achèvement disponible".

Des idées?


475
2018-05-26 00:43


origine


Réponses:


Essayer restaurer les options par défaut dans 'Windows > Preferences > Java > Editor > Content Assist > Advanced'

Un exemple du type de données que vous voyez dans cet écran de préférences, mais pas nécessairement ce que vous avez actuellement.

eclipse content assist setting

(De Vadim dans ce article de blog "Content Assist Duplicates in Eclipse (Mylyn)":
si vous avez des entrées Mylyn en double, décochez les entrées en double qui ne contiennent pas "(Mylyn)"dans leur nom)

le Eclipse page d'aide définit la liste par défaut à restaurer:

Sélectionnez les types de proposition contenus dans le liste d'assistance par défaut:

  • Autres propositions Java,
  • Propositions de modèles SWT,
  • Propositions de modèles,
  • Propositions de type

1014
2018-05-26 04:24



J'ajoute une réponse ici au cas où quelqu'un d'autre le trouverait sur Google. Mêmes symptômes; problème différent. Pour moi, les caches de type étaient devenus corrompus.

De http://mschrag.blogspot.co.nz/2009/01/open-type-cant-find-your-class.html

  • Quitter Eclipse
  • Aller à l'espace de travail / .metadata / .plugins / org.eclipse.jdt.core
  • Supprimer * .index et savedIndexNames.txt
  • Redémarrez Eclipse et recherchez Ctrl + T pour le type incriminé. Les index seront reconstruits.

54
2018-01-21 19:37



Pour ceux qui exécutent Xfce + ayant IBus plugin activé, il peut y avoir un conflit de raccourci clavier.

Voir plus d'infos sur mon blog: http://peter-butkovic.blogspot.de/2013/05/keyboard-shortcut-ctrlspace-caught-in.html 

METTRE À JOUR:

comme suggéré par le commentaire de @nhahtdh, en ajoutant quelques informations supplémentaires pour répondre directement: le plugin IBus dans Xfce utilise par défaut Ctrl+Espace raccourci pour le changement de disposition du clavier. Pour le changer, allez à: Options et changez-le en ce que vous préférez.


17
2018-05-04 05:34



Vérifiez la lib de votre projet. Il se peut que vous ayez inclus deux fichiers jar de ce type dans lesquels la même classe est disponible ou une classe de code peut être réfrénée dans deux fichiers jar. Dans ce cas aussi, eclipse cesse d'aider le code car il est totalement confus.

Une meilleure façon de vérifier cela est d'aller dans le fichier où l'assistant ne fonctionne pas et de commenter toutes les importations là-bas, d'ajouter les importations une par une et de vérifier à chaque importation si l'assistant fonctionne ou pas. .


9
2018-04-27 11:30



Aucun d'entre eux n'a fonctionné pour moi.

Je connaissais ce problème en une seule fois. Ce qui a finalement fonctionné pour moi était de supprimer la classe fautive et de la recréer. Problème résolu ... mystère pas tellement!


8
2017-11-30 11:53



Si quelqu'un vient ici et veut activer la fonction de saisie semi-automatique, allez à

Preferences -> Java -> Editor -> Content Assist. 

Puis dans le Activation automatique section remplir Déclencheurs d'activation automatique pour Java:

abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ._

enter image description here


7
2018-06-17 09:45



Si vous avez installé la barre d'outils Google pour IE, vous pouvez être confronté au même problème. Car, la barre d'outils capture le raccourci Ctrl + Espace.


5
2017-11-21 18:22



J'ai fait face à ce problème et j'ai passé des heures à essayer de comprendre le problème. J'ai essayé de suivre les étapes mentionnées dans les différentes réponses ci-dessus, la solution que j'ai trouvée est dans le même sens que Mona, mais légèrement différente. J'ai essayé d'ajouter un commentaire à la réponse de Mona mais aucune option n'était disponible. Problème avec mon éclipse était, classpath d'une manière ou d'une autre a été corrompu et tous les pots et les projets dépendants étaient manquants. après avoir pris le dernier .classpath du référentiel, cela a bien fonctionné.


4
2018-01-01 04:22



J'ai eu ce problème et comme @ Marc, seulement sur une classe particulière. J'ai découvert que j'avais besoin de désigner Open With = Java Editor. En tant que débutant Eclipse, je n'avais même pas réalisé que j'utilisais un simple éditeur.

Dans l'explorateur de paquets, faites un clic droit sur le fichier et choisissez "Ouvrir avec".


4
2017-09-11 09:59



Je suis également confronté à ce problème, mais il est résolu de manière différente. Les étapes que je suis peuvent être utiles aux autres.

  1. Faites un clic droit sur le projet (celui sur lequel vous travaillez)
  2. Accédez à Propriétés> Chemin de génération Java> Bibliothèque système JRE
  3. Cliquez sur Modifier ... sur la droite
  4. Choisissez le JRE 7

4
2018-01-17 21:41