Question Méthode Gradle DSL non trouvée: 'runProguard'


Je reçois une erreur après la mise à jour de mon dernier projet. Pas un problème dans mon code mais j'ai des problèmes avec build.gradle. Comment puis-je le réparer?

code build.gradle ici:

apply plugin: 'android'

android {
    compileSdkVersion 21
    buildToolsVersion '20.0.0'

    packagingOptions {
        exclude 'META-INF/DEPENDENCIES'
        exclude 'META-INF/LICENSE'
        exclude 'META-INF/LICENSE.txt'
        exclude 'META-INF/license.txt'
        exclude 'META-INF/NOTICE'
        exclude 'META-INF/NOTICE.txt'
        exclude 'META-INF/notice.txt'
        exclude 'META-INF/ASL2.0'
    }

    defaultConfig {
        applicationId 'com.xxx.axxx'
        minSdkVersion 14
        targetSdkVersion 19
        versionCode 6
        versionName '1.0'
    }
    buildTypes {
        release {
            runProguard false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
    productFlavors {
    }
}

dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    compile 'com.android.support:appcompat-v7:19.+'
    compile files('libs/commons-codec-1.8.jar')
    compile files('libs/asmack-android-8-4.0.4.jar')
    compile 'com.android.support:support-v4:21.0.0'
    compile 'com.google.code.gson:gson:2.2.4'
    compile 'com.jakewharton:butterknife:5.1.1'
}

Gradle Sync message output:

Error:(27, 0) Gradle DSL method not found: 'runProguard()'
**Possible causes:
The project 'Atomic4Mobile' may be using a version of Gradle that does not contain the method.
**Gradle settings**
The build file may be missing a Gradle plugin.
**Apply Gradle plugin**

481
2017-11-22 13:44


origine


Réponses:


enter image description hereSi vous utilisez la version 0.14.0 ou supérieure du plugin Gradle, vous devez remplacer "runProguard" avec "minifyEnabled" dans vos fichiers build.gradle.

runproguard a été renommé en minifyEnabled dans la version 0.14.0. Pour plus d'informations, Voir le système de construction Android 


814
2017-11-24 14:44



En utilisant 'minifyEnabled' au lieu de 'runProguard'fonctionne correctement.

Previous code :

buildTypes {
        release {
            runProguard false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt'
        }
    }

Current code :

buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt'
        }
    }

J'espère que cela t'aides .


279
2017-12-03 07:54



Si vous effectuez une migration vers la version 1.0.0, vous devez modifier les propriétés suivantes.

Dans le fichier build.gradle du projet, vous devez remplacer minifyEnabled.

Par conséquent, votre nouveau type de construction devrait être

buildTypes {
        release {
            minifyEnabled true
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt'        }
    }

Assurez-vous également que la version Gradle est 1.0.0 comme

classpath 'com.android.tools.build:gradle:1.0.0'

dans le fichier build.gradle.

Cela devrait résoudre le problème.

La source: http://tools.android.com/tech-docs/new-build-system/migrating-to-1-0-0


71
2017-12-09 06:58



En changeant runproguard à minifyEnabled, une partie de l'issue est fixée.

Mais le correctif peut provoquer des "projets de bibliothèque ne peuvent pas définir l'ID d'application" (vous pouvez trouver le correctif pour cela ici Android Studio 1.0 et erreur "Les projets de bibliothèque ne peuvent pas définir l'application").

En supprimant l'ID de l'application dans le fichier build.gradle, vous devriez être prêt à partir.


17
2018-02-05 15:59



runproguard a été renommé en minifyEnabled dans la version 0.14.0 (2014/10/31) ou plus dans Gradle.

Pour résoudre ce problème, vous devez changer runProguard en minifyEnabled dans le build.gradle fichier de votre projet.

enter image description here


1
2018-05-22 08:11