Question pylint ignore par répertoire


Est de pylint docs:

--ignore=<file>
    Add <file or directory> to the black list. It should be a base name, not a path. You may set this option multiple times. [current: %default]

Pourtant, je n'ai pas de chance de faire fonctionner la partie répertoire.

J'ai un répertoire appelé migrations, qui contient des fichiers de migration django-south. Comme j'entre --ignore = migrations, il continue de me donner les erreurs / avertissements dans les fichiers du répertoire de migration.

Serait-ce cela --ignore ne fonctionne pas pour les répertoires?

Si je pouvais même utiliser regexp pour faire correspondre les fichiers ignorés, cela fonctionnerait, puisque les fichiers django-south sont tous nommés 0001_something, 0002_something ...


Étant donné que je ne pouvais pas faire ignorer l’annuaire, je me suis contenté de mettre # pylint: disable-msg-cat=WCREFI en haut de chaque fichier de migration, qui ignore toutes les erreurs de pylint, les avertissements et les informations.


20
2018-03-23 21:20


origine


Réponses:


Ajouter:

[MASTER]
ignore=migrations

Pour mon .pylintrc fonctionne avec pylint 0.25. Mes problèmes sont avec PyDev qui (semble-t-il) ne respecte pas mes paramètres. Cela est dû, je pense, au fait qu’il exécute pylint par fichier, ce qui, à mon avis, contourne les contrôles «ignore», que ce soit pour les modules / répertoires ou les fichiers. Les appels à pylint de PyDev ressemblent à ceci:

/path/to/site-packages/pylint/lint.py --include-ids=y /path/to/project/migrations/0018_migration.py

16
2017-12-08 06:40



Vous ne pouvez pas donner un chemin mais uniquement le "nom de base" du répertoire. Par exemple. utilisation --ignore=lib au lieu de --ignore-=appengine-toolkit/gaetk/lib.

Le problème est que vous allez ignorer tout répertoires nommés lib.


6
2017-09-09 13:07



Vous pouvez ensuite utiliser l'expansion Bash à votre avantage:

--ignore=migrations/{0000..1000}_something

-1
2018-03-24 07:57