Question Comment rendre le thème de couleur dans #ifdef plus lisible dans Eclipse?


J'adore les thèmes de couleur (merci!), Mais un problème sérieux est que le code # ifdef'd est impossible à lire (et énervant). Si je souligne ces lignes, je peux le lire, mais je préfère vraiment ne pas le voir du tout. Semble être un problème similaire à celui des astuces, mais j'espère qu'il existe un paramètre quelque part pour désactiver la coloration syntaxique pour le code inactif. Je l'ai regardé et je ne l'ai pas trouvé, mais cela ne signifie pas nécessairement qu'il n'existe pas. Je suis optimiste (à cet égard de toute façon).


20
2018-06-05 19:51


origine


Réponses:


Vous pouvez désactiver la mise en évidence #ifdef en allant sur:

Fenêtre -> Préférences -> C / C ++ -> Editeur   et décocher la case "Mettre en surbrillance le code inactif".

Vous pouvez également modifier la couleur de mise en évidence #ifdef en accédant à ce même écran et en modifiant la couleur "Surlignage de code inactif" (rubrique "Options d'apparence") pour obtenir une couleur plus adaptée à votre cas.


39
2017-08-02 19:23



Fenêtre -> Préférences -> C / C ++ -> Éditeur -> Options du code d'apparence -> Mise en évidence du code inactif Choisissez une autre couleur. Je préfère le gris.

Je recommande également de modifier les arrière-plans d’occurrences: Général -> Editeurs-> Editeurs de texte -> Annotations -> Occurrences C / C ++


10
2017-09-24 11:10



J'ai trouvé ça: https://github.com/eclipse-color-theme/eclipse-color-theme/issues/35

"Préférences -> C / C ++ -> Editeur," Mettre en surbrillance le code inactif "coché, Options de couleur d'apparence: Surlignage de code inactif."

Cela désactive la mise en évidence des parties inactives du code, les rendant à nouveau lisibles. Je n'ai pas encore trouvé de moyen de changer la couleur de mise en évidence.


5
2018-06-14 21:27



Eh bien, j'ai trouvé une réponse partielle:

Préférences -> C / C ++ -> Editeur -> Mise en évidence de la syntaxe -> Préprocesseur -> Directives a changé la couleur de premier plan en noir.

Préférences -> C / C ++ -> Editeur -> Mise en évidence de la syntaxe -> Préprocesseur -> Autres a changé la couleur du premier plan en noir

Préférences -> C / C ++ -> Editeur -> Mise en évidence de la syntaxe -> Code -> Autres a changé la couleur du premier plan en noir.

Au moins maintenant je peux le voir. Quelqu'un sait comment / où changer la couleur de fond de ces blocs?

Merci!


3
2018-06-05 20:08