Question Xcode 6: Le clavier n'apparaît pas dans le simulateur


Le clavier n'apparaît pas lorsque je lance le simulateur et clique dans l'UITextView. Comment réactiver le clavier?

Cela fonctionnait mais maintenant ça ne fonctionne pas - je ne sais pas ce que j'ai cliqué par accident ... des conseils seraient appréciés!


591
2018-06-26 00:53


origine


Réponses:


J'ai eu le même problème. Ma solution était la suivante:

  1. iOS Simulator -> Hardware -> Clavier
  2. Décochez "Connecter le clavier matériel"

Le mien a été vérifié parce que j'utilisais mon clavier mac, mais si vous vous assurez qu'il est décoché, le clavier de l'iPhone apparaîtra toujours.


1107
2018-06-30 19:43



Lors des tests dans le simulateur bêta ios8, vous pouvez basculer entre le "clavier logiciel" et le "clavier matériel" avec +K.

METTRE À JOUR: Depuis iOS Simulator 8.0, le raccourci est ++K.


310
2017-07-31 07:47



Simulateur -> Matériel -> Clavier -> Toggle Software Keyboard devrait résoudre ce problème.

Simulator->Hardware->Keyboard->Toggle Software Keyboard


76
2017-10-17 03:32



Cela semble être un bug dans iOS 8. Il existe deux solutions à ce problème:

  1. Basculer entre le clavier du simulateur et le clavier du MacBook en utilisant Commander+K raccourci.

  2. Rattachez le clavier au simulateur:

    une. Ouvrir un simulateur

    b. Sélectionner Hardware -> Clavier

    c. Décochez et puis vérifiez 'Connecter le clavier matériel'

Screenshot for step 2

OU appuyez simplement sur Décalage + Commander + K raccourci


50
2017-11-12 09:59



Pour activer / désactiver le clavier du simulateur,

⌘ + K (Ctrl + k)

Pour désactiver la saisie de votre clavier,

iOS Simulator -> Matériel -> Clavier -> Décochez "Connect Hardware Keyboard"


25
2017-11-08 10:53



Vous pouvez utiliser : ++K pour montrer le clavier sur le simulateur.


15
2017-10-27 12:37



Il serait difficile de dire s'il y a un problème avec votre code sans le vérifier, mais cela m'arrive beaucoup (Version 6.0 (6A216f)). Je dois généralement réinitialiser le contenu et les paramètres du simulateur et / ou redémarrer xCode pour le faire fonctionner à nouveau. Essayez-les et voyez si cela résout le problème.


11
2018-06-26 00:56



Si le clavier n'apparaît pas automatiquement dans le simulateur, appuyez simplement sur [Commande + K]

ou Hardware -> Clavier -> Clavier logiciel à bascule 


4
2017-11-15 05:25



Pour résoudre le problème, suivez ceci -

  1. Quittez Xcode et le simulateur
  2. Appuyez sur 'command + shift + g' ... cela ouvrira la boîte de dialogue "go to folder".
  3. tapez "~ / Library / Preferences" dans cette boîte de dialogue pour accéder à votre dossier de préférences.
  4. Supprimer "com.apple.iphonesimulator.plist" dans ce dossier
  5. Terminé. "Com.apple.iphonesimulator.plist" sera régénéré lorsque vous redémarrerez le simulateur.

Sinon, vous pouvez également le faire avec une seule commande.

Ouvrir le terminal et le feu - 1. rm ~ / Bibliothèque / Preferences / com.apple.iphonesimulator.plist

Cela fera l'affaire en une seule étape! Assurez-vous juste de quitter Xcode et le simulateur avant de lancer ceci.


1
2017-10-05 21:47



La manière simple est juste commande de presse + k


0
2017-09-23 07:39