Question Android Studio: "Veuillez sélectionner Android SDK"


Après une importation réussie d'un projet Eclipse-Android dans "Android Studio 1.4", j'obtiens l'erreur "Please select Android SDK" quand je clique sur le bouton pour exécuter l'application en simulateur.

Mais je ne trouve aucun moyen de le faire.

Cette boîte de dialogue s'ouvre lorsque je clique sur "Exécuter":

This dialog opens up when i click on "run"

C'est le dialogue "structure du projet":

enter image description here

Qu'est-ce que je devrais faire maintenant?


616
2017-12-18 10:16


origine


Réponses:


je vais à build.gradle et cliquez synchroniser maintenant. Alors ça a marché.

Mettre à jour :

Fichier -> Projet de synchronisation avec des fichiers Gradle (Android Studio 3.1.1)

Outils -> Android -> Projet de synchronisation avec les fichiers Gradle (Android Studio 3.0.1) Ou vous pouvez cliquer sur l'icône dans la barre d'outils.

Sync Project Icon

Cette réponse ne va peut-être pas fonctionner pour les versions ultérieures car l'équipe Android studio travaille à améliorer l'outil, la manière de synchroniser peut être différente dans la prochaine version d'Android Studio.

FAÇON COMMUNE cela peut aider est d'essayer de projet de synchronisation et alors Invalider les caches et Redémarrer Android Studio.

Solution pour Android Studio 3.1.2  [Voir ci-dessous réponse]

Voir Dernière version d'Android Studio


1320
2017-11-01 08:57



FIX POUR 3.1.2 OU VERSIONS PLUS NOUVELLES

Moi et certains de mes collègues ont fait face au même problème AS 3.1.2, mais une simple synchronisation ne nous a pas aidé. Pour nous, la solution était un peu différente:

  1. Fichier -> Invalider les caches -> Invalider
  2. Fichier -> Fermer le projet.
  3. Supprimez le projet de la fenêtre de sélection de projet AS.
  4. Quitter d'Android Studio
  5. Démarrez AS et ouvrez à nouveau le projet

reopen project intructions

CONSEILS SUPPLÉMENTAIRES SI VOUS FACE À CE PROBLÈME CONSTAMMENT 

Certains d'entre vous sont constamment confrontés à ce problème, et cette "solution" ne le résout que temporairement. Au moment où nous avons commencé à avoir cette erreur, nous avons utilisé Gradle wrapper 4.6 et Android gradle plugin 3.1.0, mais depuis, nous sommes revenus à 4.4 et nous l'utilisons avec le dernier plugin Android gradle, et nous n'avons pas vu ce problème depuis.


265
2018-04-24 11:20



Cliquez sur cette icône enter image description here synchroniser gradle 

ou éditez n'importe lequel de votre module gradle puis synchroniser


197
2017-09-15 08:13



Dans Android Studio 3 et ci-dessus, à la fois pour Windows, Mac et Linux:

File -> Sync Project with Gradle Files

Résolu! Ou vous pouvez le faire en touche de raccourci:

presse ⌘ + Maj + A (Mac) ou Ctrl + Maj + A (Windows, Linux). Puis pop-up un texte d'édition et écrire  "Sync Project with Gradle Files". Puis double-cliquez sur l'option.

Votre problème a été résolu! Il va synchroniser votre fichier Gradle avec votre fichier de projet, merci.

Capture d'écran: 

Screenchot


110
2018-06-20 14:34



presse "Ctrl+shift+A" et dans la fenêtre pop-up EditText, écrire "Sync Project with Gradle Files". Après cela, double-cliquez sur l'option apparue. Il va ensuite synchroniser votre Gradle fichier SDK avec le fichier de projet.


96
2018-02-15 14:00



Il suffit d'aller à la (niveau de l'application)  build.gradle fichier, donnez un espace vide quelque part et cliquez sur synchroniser, une fois que gradle montre synchronisation complète alors l'erreur sera partie


71
2018-03-07 07:00



Maintenant, sur Android Studio 3 et supérieur, vous pouvez essayer de synchroniser le projet avec gradle comme:

File -> Sync Project with Gradle Files

enter image description here


34
2018-06-04 05:33