Question Erreur: java: javacTask: la version source 8 requiert la version cible 1.8


L'utilisation d'IntelliJ IDE ne peut compiler aucun projet. Captures d'écran des paramètres ci-dessous:

JDK d'occasion:

http://gyazo.com/b6e32119af7b04090d890cad04db6373

Project SDK et niveau de langue:

http://gyazo.com/55a5fc9f7f2bb721a04780ce9d74eeab

Niveau de langue:

http://gyazo.com/143bffad63fd89cafc231298729df2fc

Quelqu'un a des idées?


625
2018-04-27 06:24


origine


Réponses:


  1. Fichier> Paramètres> Générer, Exécution, Déploiement> Compilateur> Compilateur Java
  2. Changement Version de bytecode cible à 1.8 du module pour lequel vous travaillez.

Si vous utilisez Maven

Ajouter le plugin du compilateur à pom.xml sous le niveau supérieur project nœud:

<build>
    <plugins>
        <plugin>
            <groupId>org.apache.maven.plugins</groupId>
            <artifactId>maven-compiler-plugin</artifactId>
            <configuration>
                <source>1.8</source>
                <target>1.8</target>
            </configuration>
        </plugin>
    </plugins>
</build>

(Hissé des commentaires.)

Remarque: Si cela ne vous dérange pas de réimporter votre projet, alors la seule chose que vous devez vraiment faire est de changer le pom et de réimporter le projet, puis IntelliJ choisira les paramètres corrects et vous ne devrez pas les changer manuellement.


1388
2018-05-29 08:31



Vous devez aller à Paramètres et définir dans le compilateur Java ce qui suit: enter image description here

Vérifiez également les paramètres du projet


135
2017-08-21 13:05



Cela ressemble au type d'erreur que génère Maven lorsque le plugin du compilateur n'est pas configuré correctement. Voici un exemple de configuration de compilateur Java 8.

<project xmlns="http://maven.apache.org/POM/4.0.0"
     xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
     xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">

<!-- ... -->

    <build>
        <plugins>
            <plugin>
                <groupId>org.apache.maven.plugins</groupId>
                <artifactId>maven-compiler-plugin</artifactId>
                <version>3.5.1</version>
                <configuration>
                    <source>1.8</source>
                    <target>1.8</target>
                </configuration>
            </plugin>
        </plugins>
    </build>

<!-- ... -->

</project>

103
2018-04-27 07:36



  • presse:CTRL + DÉCALAGE + UNE (Pour Mac  + DÉCALAGE + UNE)
  • type: java compiler
  • presse: ENTRER

Dans la fenêtre de configuration, définissez le bytecode cible sur 1.8

(ou 1.9 pour java9)


58
2017-11-20 12:45



Il y a deux façons de résoudre ce problème:

  1. Définir les paramètres (File -> Settings -> Build, Execution, Deployment -> Java Compiler): enter image description here
  2. Ajouter une section de construction à votre pom.xml: enter image description here

25
2017-11-16 19:01



Beaucoup de réponses concernant Maven sont correctes mais vous n'avez pas besoin de configurer le plugin directement.

Comme décrit sur le page wiki du plugin Apache Maven Compiler, vous pouvez simplement définir les 2 propriétés utilisées par le plugin.

<project>
  [...]
  <properties>
    <maven.compiler.source>1.8</maven.compiler.source>
    <maven.compiler.target>1.8</maven.compiler.target>
  </properties>
  [...]
</project>

11
2017-12-09 08:48



J'ai réparé cela en allant à Structure du projet -> Modules, trouvez le module en question, cliquez sur Dépendances onglet, changer Module SDK à Project SDK.


10
2017-12-17 00:20



Je l'ai corrigé en changeant la version de compilation cible en 1.8. C'est dedans:

Fichier >> Paramètres >> Générer, Exécution, Déploiement >> Compilateur >> Compilateur Java


8
2018-04-11 20:04



Dans mon cas, j'ai résolu ce problème en ouvrant fichier .iml du projet (il est situé dans le dossier racine du projet et porte le même nom que le nom du projet) et change de ligne <orderEntry type="jdk" jdkName="1.7" jdkType="JavaSDK" /> à <orderEntry type="jdk" jdkName="1.8" jdkType="JavaSDK" /> 

J'ai tout configuré comme dans d'autres réponses ici, mais par une certaine raison Idée mis à jour le fichier .iml incorrectement.


3
2018-01-28 12:06