Question Erreur - Impossible d'accéder à la métabase IIS


Après l'installation de Visual Studio 2012 et l'ouverture de ma solution, j'obtiens une série d'erreurs dans ce formulaire:

L'application Web Project Foo est configurée pour utiliser IIS.
  Impossible d'accéder à la métabase IIS. Vous n'avez pas les privilèges suffisants pour accéder aux sites Web IIS sur votre ordinateur.

J'obtiens ceci pour chacune de nos applications Web. Choses que j'ai essayées:

  1. Exécuter Visual Studio en tant qu'administrateur
  2. Exécution de aspnet_regiis.exe -ga MyUserName
  3. Exécution de aspnet_regiis.exe -i

Ceux-ci semblent être des solutions communes à ce problème mais je n'ai eu aucun succès avec eux. Y at-il autre chose que je peux essayer de faire?


762
2017-10-12 13:15


origine


Réponses:


Sur Windows 8 Pro:

%systemroot%\inetsrv\config

Sur Windows 7 et 8.1 et 10

%systemroot%\System32\inetsrv\config 

(Où %systemroot% est habituellement C:\Windows)

Accédez à l'emplacement approprié ci-dessus dans l'Explorateur Windows. Vous serez bloqué l'accès avec un popup qui dit:

"Vous n'avez pas accès à ce dossier - Cliquez sur continuer pour accéder en permanence à ce dossier"

Cliquez sur "continuer" pour ce dossier, et avec le dossier d'exportation ci-dessous. J'ai changé le raccourci en "Exécuter en tant que moi" (membre du domaine et des administrateurs locaux) et j'ai pu ouvrir et déployer la solution.


1349
2017-07-04 01:58



Je pense que vous n'utilisez pas Visual Studio avec des autorisations d'administrateur. Regarde ça:

http://bloggingabout.net/blogs/rick/archive/2012/10/04/unable-to-access-the-iis-metabase.aspx

Citer

La solution à ce problème est simple: démarrez votre Visual Studio avec "Exécuter en tant que   Administrateur. "Vous pouvez le faire en cliquant droit sur le raccourci et   sélectionner "Exécuter en tant qu'administrateur".


235
2017-10-12 13:19



Je pense que nous avons rencontré un problème similaire au travail. Pour nous, la solution était d'aller dans Panneau de configuration -> Programmes et fonctionnalités -> Activer ou désactiver des fonctionnalités Windows ... à l'intérieur, nous devions sélectionner Internet Information Services -> Outils de gestion Web -> IIS 6 Management Compatibility -> La métabase IIS et la compatibilité de configuration IIS 6. Windows Features dialog showing IIS Metabase option

Essayez-le et faites le moi savoir si ça aide!

Remarque: Nous exécutons IIS 7.5 sous Windows 7 en utilisant Visual Studio 2005 et 2010 et en faisant des choses avec des WebServices super-old-school (.asmx) ...


47
2017-10-12 13:39



J'ai résolu ce problème en accordant des autorisations d'identité IIS AppPool au %systemroot%\inetsrv\config


31
2018-05-05 22:06



Si vous travaillez sur un projet qui ne nécessite pas l'utilisation d'IIS, alors une solution de contournement pour ouvrir le projet avec cette erreur est simplement de cliquer avec le bouton droit sur le projet déchargé et de cliquer sur Modifier, recherchez:

<ProjectExtensions>
    <VisualStudio>
      <FlavorProperties GUID="">
        <WebProjectProperties>
          <UseIIS>True</UseIIS>
        </WebProjectProperties>
      </FlavorProperties>
    </VisualStudio>
  </ProjectExtensions>
</Project>

et définissez USEIIS sur false

<UseIIS>False</UseIIS>

rechargez le projet en cliquant droit dessus après avoir sauvegardé les modifications.


25
2017-08-06 05:57



J'ai eu deux types de problèmes séparés conduire à cette erreur, et je pensais partager ...

1. The directory was on an network share and due to UAC restrictions, was 
   unable to be accessed -- even when running as an admin.
2. The directory was on a drive that didn't exist...

Les deux proviennent d'un malheureux (imo) choix de MS de mettre des choses dans le répertoire Documents ou Mon Document, combinées avec des messages d'erreur vraiment moche. Dans les deux cas ci-dessus, le problème fondamental était que Fichier de configuration IISExpress va dans Mes documents, et il n'existe pas ou n'a pas pu être consulté.


18
2017-10-04 06:38



Merci à tous ceux qui ont répondu. Comme cela a été fermé pendant longtemps, je n'ai pas pu fournir beaucoup de commentaires, mais j'ai finalement résolu mon problème. J'ai essayé beaucoup de ces autres solutions et elles n'ont pas résolu mon problème, mais je suis sûr qu'elles aident quand la cause première est différente.

Ma solution

J'ai résolu ce problème en désactivant les fonctionnalités IIS et .Net Framework dans Windows 7, puis en les réactivant. Il semble que cette réinstallation est ce qui a résolu mon problème. Je ne sais toujours pas ce qui a causé le problème, mais au moins un autre développeur de mon équipe a eu le même problème.


12
2018-02-05 19:30



J'ai eu ce problème - les symptômes étaient les mêmes, mais le problème que j'avais était que j'avais mis le dossier "Mes documents" sur un partage réseau, et le partage n'était pas accessible.

Le problème racine était que les fichiers de configuration IIS situés à% USERPROFILE% \ Documents ne sont pas accessibles. Une fois que j'ai changé l'emplacement du dossier "Mes documents" (j'ai modifié la valeur reg), il a recommencé à fonctionner.

Je sais que ce n'est peut-être pas un scénario courant que vous pourriez rencontrer, mais je l'ai posté ici parce qu'il donne les mêmes symptômes.


11
2018-02-15 22:15



Sur une fenêtre 81, à partir d'une invite de commande d'administration, utilisez:

icacls "C:\Windows\System32\inetsrv\config" /t /grant "IIS AppPool\DefaultAppPool":(R)

Puis revenez dans VS, faites un clic droit sur le projet a échoué, choisissez Recharger.

Crédit à: Vue d'ensemble des autorisations IIS7 - ApplicationPoolIdentity


10
2017-09-09 15:12



Vous pourriez rencontrer ce problème et avoir le même problème que moi. Je l'ai "résolu" avant et puis panne de courant et l'ordinateur s'est écrasé, pas sûr pourquoi un enregistrement réglage est revenu mais c'est le LA SOURCE de mon problème.

  1. J'ai essayé tout le fonctionnement en tant qu'administrateur
  2. Tous les IIS / IIS expriment des réinstallations.
  3. Divers "hacks"

Entré à devoir réparer le registre à nouveau.

  1. Impossible d'ouvrir regedit en tant qu'administrateur (Nécessité d'accéder au registre car le problème n'est pas avec le template admin gpedit.msc)

  2. UnHookExec.inf sur le bureau

Enregistrez simplement UnHookExec.inf et installez-le en cliquant avec le bouton droit et en sélectionnant l'installation. L'installation du fichier n'affiche aucune fenêtre contextuelle ou d'avis. http://www.tweakandtrick.com/2011/04/enable-regedit-registry-editor.html

  1. HKEY_CURRENT_USER \ Software \ Microsoft \ Windows \ CurrentVersion \ Explorateur \ Dossiers Shell utilisateur \ Personnel pointant vers partage de fichiers inexistant. Changer cela en chemin local a résolu ce problème pour moi. - Pasi Savolainen 14 juillet 14 à 08:41

(changé de \\cs2data\home\stickelt\my documents  à c:\dev  )

À présent Tout est bon et Visual Studio a ouvert la solution avec 15 projets et se connecte à IIS et ne se plaint pas de ne pas pouvoir accéder aux métadonnées iis

Je n'avais jamais rencontré ça auparavant, car personne à l'emploi actuel n'avait ce problème (beaucoup sont là depuis longtemps, certains ont eu des clones d'autres machines qui "fonctionnaient" et beaucoup sont sur un autre domaine etc.)


7
2017-07-01 20:11



Je suis tombé sur ceci aujourd'hui et ai résolu le problème en enlevant le IISUrl du dossier de projet:

  1. Projet clic droit
  2. Cliquez sur Modifier
  3. Supprimer la ligne suivante:

     <IISUrl>http://localhost:xxxxx </IISUrl>
    
  4. Recharger le projet

  5. Maintenant, ajoutez un nouveau répertoire virtuel IIS en faisant un clic droit sur Projet> Propriétés> Web et en sélectionnant Utiliser le serveur Web IIS local (décochez Utiliser IIS Express) et en cliquant sur le bouton Créer un répertoire virtuel.

6
2018-03-16 12:06