Question Impossible de démarrer Eclipse - Java a été démarré mais a renvoyé le code de sortie = 13


J'essaie d'obtenir mon premier aperçu du développement Android en utilisant Eclipse. J'ai rencontré ce problème en essayant d'exécuter Eclipse, après avoir installé la version 4.2 il y a quelques minutes.

Après avoir essayé de démarrer Eclipse sans aucun paramètre pour spécifier la machine virtuelle Java, j'ai reçu un message d'erreur indiquant qu'elle ne trouvait pas de machine Java nommée javaw.exe dans le dossier Eclipse. J'ai donc trouvé où Java était installé et spécifié le paramètre dans la cible du raccourci. Maintenant, je reçois une erreur différente, "Java a été démarré mais a renvoyé le code de sortie = 13".

Des questions similaires semblent indiquer qu'il s'agit d'un conflit 32 bits / 64 bits, mais je suis 99% positif que j'ai téléchargé des versions 64 bits d'Eclipse et Java (RE 7u5), que j'ai choisi parce que j'ai 64 bits Windows 7.

  • Si quelqu'un sait comment confirmer que mon Eclipse et Java sont en 64 bits, ce serait apprécié.
  • Si vous pensez que mon problème est différent, aidez s'il vous plaît!
  • Parlez aussi clairement que possible car je suis totalement nouveau à Eclipse et Java.

Raccourci Cible: "C: \ Program Files \ Eclipse-SDK-4.2-win32-x86_64 \ éclipse \ eclipse.exe" -vm "C: \ Program Files (x86) \ Java \ jre7 \ bin \ javaw.exe"

Code d'erreur complet ...:

Java was started but returned exit code=13
C:\Program Files (x86)\Java\jre7\bin\javaw.exe
-Xms40m
-Xmx512m
-XX:MaxPermSize=256m
-jar C:\Program Files\Eclipse-SDK-4.2-win32-x86_64\eclipse\\plugins/org.eclipse.equinox.launcher_1.30v20120522-1813.jar
-os win32
-ws win32
-arch x86_64
-showsplash C:\Program Files\Eclipse-SDK-4.2-win32-x86_64\eclipse\\plugins\org.eclipse.platform_4.2.0.v201206081400\splash.bmp
-launcher C:\Program Files\Eclipse-SDK-4.2-win32-x86_64\eclipse\eclipse.exe
-name Eclipse
--launcher.library C:\Program Files\Eclipse-SDK-4.2-win32-x86_64\eclipse\\plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.200.v201205221813\eclipse_1503.dll
-startup C:\Program Files\Eclipse-SDK-4.2-win32-x86_64\eclipse\\plugins/org.eclipse.equinox.launcher_1.30v20120522-1813.jar
--launcher.overrideVmargs
-exitdata 1e30_5c
-vm C:\Program Files (x86)\Java\jre7\bin\javaw.exe
-vmargs
-Xms40m
-Xmx512m
-XX:MaxPermSize=256m
-jar C:\Program Files\Eclipse-SDK-4.2-win32-x86_64\eclipse\\plugins/org.eclipse.equinox.launcher_1.30v20120522-1813.jar

813
2017-07-12 22:23


origine


Réponses:


Il existe des combinaisons de travail de bits OS, JDK et Eclipse. Dans mon cas, j'utilisais un JDK 64 bits avec une Eclipse 32 bits sur un système d'exploitation 64 bits. Après la rétrogradation du JDK en 32 bits, Eclipse a commencé à fonctionner.

Veuillez utiliser l'une des combinaisons suivantes.

  • Système d'exploitation 32 bits, JDK 32 bits, Eclipse 32 bits (32 bits uniquement)
  • Système d'exploitation 64 bits, JDK 32 bits, Eclipse 32 bits
  • Système d'exploitation 64 bits, JDK 64 bits, Eclipse 64 bits (64 bits uniquement)

102
2018-01-03 10:54



Votre version d'Eclipse est 64 bits, en fonction des chemins d'accès et des noms de fichiers. Cependant, la version de Java qu'il prend est 32 bits, comme indiqué par l'origine, sur cette ligne:

-vm C:\Program Files (x86)\Java\jre7\bin\javaw.exe

Program Files (x86) est le dossier où Windows 64 bits 32 bits programmes.

Program Files est le dossier où Windows 64 bits 64 bits programmes.

Cela peut arriver quand un système a plus d'une JVM installée, comme c'est souvent le cas sur Windows 64 bits (par exemple, la page de téléchargement JRE utilise le bit-ness du navigateur pour déterminer quel téléchargement de bits à offrir, et beaucoup de gens utilisent (d) les navigateurs 32 bits même s'ils exécutent Windows 64 bits).

Le meilleur moyen de résoudre ce problème, en supposant que vous ayez en fait un JRE ou un JDK 64 bits sur votre système, est de spécifier eclipse.ini exactement quelle JVM vous voulez utiliser. Les instructions sont détaillées dans la page wiki Eclipse, mais en gros, vous devez spécifier le -vm option dans le fichier ini - assurez-vous de lire attentivement la page wiki car le format est très spécifique.

Spécification du chemin JVM dans eclipse.ini est fortement recommandé car cela permet d'isoler Eclipse de tout changement potentiel de votre système PATH que certains installateurs de programmes pourraient faire (je vous parle, Oracle!).

Une autre option serait de télécharger et d'utiliser Eclipse 32 bits au lieu de 64 bits, mais il est toujours fortement recommandé de spécifier le chemin d'accès à la JVM dans eclipse.ini.


Gauche pour référence historique:

Pour vérifier votre version de Java, exécutez

  java -version

dans une console (invite de commande). Sur Windows 7 avec Java 6 64 bits, j'ai:

  Version Java "1.6.0_27"
  Java (TM) SE Runtime Environment (build 1.6.0_27-b07)
  Machine virtuelle Java HotSpot (TM) 64 bits (version 20.2-b06, mode mixte)

Notez la troisième ligne, qui montre qu'il s'agit d'une version 64 bits.

Sur une version 32 bits, vous obtiendrez quelque chose comme:

  VM client HotSpot (TM) Java (build 20.1-b02, mode mixte, partage)

668
2017-07-12 22:29



J'ai eu cette erreur et j'ai trouvé que ma variable PATH (sous Windows) était probablement modifiée. D'abord dans mon PATH était cette entrée:

C:\ProgramData\Oracle\Java\javapath

... et Eclipse couru "C:\ProgramData\Oracle\Java\javapath\javaw" - qui a donné l'erreur. Je pense que c'est quelque chose qui est venu avec une installation de Java 8.

J'ai plusieurs versions Java installées (6, 7 et 8), donc j'ai supprimé cette entrée de la PATH et j'ai essayé de redémarrer Eclipse, ce qui a bien fonctionné.

Instructions sur la modification de la variable PATH


225
2017-11-03 07:20



Si vous avez récemment installé Java 8 et désinstallé Java 7, installez JDK 8 et réessayez.


178
2017-10-30 14:06



Pour moi, la solution était d'aller dans (sur Windows 8.1):

System > Advanced system setting > Environment Variables 

Sous 'Variables système' dans la variable 'Chemin', il y avait le premier suivant:

C:\ProgramData\Oracle\Java\javapath;

J'ai enlevé ceci et Eclipse a fonctionné encore!


112
2017-12-03 07:03



J'ai eu le même problème, Java a été démarré mais a renvoyé le code de sortie = 13.

Ma solution consistait à créer une variable d'environnement pour les propriétés Windows Nom de variable = CHEMIN valeur variable = C: \ Program Files \ Java \ jdk1.7.0_02 \ bin, ne pas C: \ Program Files (x86) \ Java \ jre7 \ bin.

Ensuite, j'ai ajouté une ligne au fichier eclipse.ini → C: \ Programmes \ Java \ jdk1.7.0_02 \ bin \ javaw.exe.

Cela a fonctionné pour moi.


64
2018-01-23 09:22



La solution la plus étrange qui soit. Regardez votre chemin Eclipse, et assurez-vous que vous n'avez pas de caractères étranges (comme !, #, et @). Cela a fonctionné pour moi.


22
2017-12-04 10:50



enter image description here

Le problème a été résolu en procédant comme suit.

  1. Eclipse trouve les exécutables JAVA de 'C: \ ProgramData \ Oracle \ Java \ javapath'

  2. La structure du dossier contiendra des raccourcis vers les exécutables ci-dessous,
    je. java.exe
    ii. javaw.exe
    iii. javaws.exe

  3. Pour moi, les chemins exécutables pointaient vers mon Fichiers de programme (x86) (accueil pour les applications 32 bits) emplacement du dossier

  4. Je l'ai corrigé Fichiers de programme (qui héberge des applications 64 bits) et le problème a été résolu

S'il vous plaît trouver la capture d'écran pour le même.


22
2017-12-13 18:20



L'ajout de l'argument vm au fichier .ini a fonctionné pour moi

-vm
C:\Program Files\Java\jdk1.7.0_65\bin\javaw.exe

16
2018-03-16 13:52